DDF Creator DMXC2

Aus DMXCWiki
Wechseln zu: Navigation, Suche

Books.png DDF Creator DMXC2 Artikel beschreibt
DDFCreator 2.2
Arrow back.png DDF
Beamertool Plugin Arrow forw.png
Inhaltsverzeichnis

 

Inhaltsverzeichnis

Die Arbeit mit dem DDFCreator

Achtung wichtiger Hinweis Im DDFCreator sind nicht alle möglichen Tags und Attribute zur DDF-Erstellung enthalten. Diese müssen bei Bedarf von Hand nachgetragen werden. (minvalue; maxvalue; virtual)

Überblick

DDFCreator installieren und einrichten

Nachdem Sie die Installationsdatei des DDFCreators von der Homepage heruntergeladen haben, müssen Sie diese starten. Installieren Sie den DDFCreator in ein Verzeichnis ihrer Wahl. Anschließend starten Sie den DDFCreator über das Startmenü.

Der Editor benötigt zum Arbeiten den Ordner, in dem die Bilddaten für die DDFs abgelegt werden. Dieser wird automatisch bei der Installation von DMXControl mitgeliefert. Sie können zwar auch ohne Angabe des Ordners arbeiten, werden dann aber im DDF kein Deviceimage angezeigt bekommen. Nach einem Klick auf OK, öffnet sich das Einstellungsfenster des DDFCreators, in dem Sie Einstellungen am Programm vornehmen können:

Abbildung 33.1:Konfigurationsfenster des DDFCreators
Abbildung 33.1: Konfigurationsfenster des DDFCreators


In diesem Fenster können Sie das Raster An und Aus schalten, die Rasterung einstellen, die Sprachdatei

auswählen und den Images Ordner angeben. Dieser befindet sich im Installationsverzeichnis von DMXControl im

Unterverzeichnis Devices. Also z.B.: C:\Programme\DMXControl\Devices\Images.

Sie können den Ordner eintippen, oder über einen Auswahldialog angeben. Der Ordnerauswahldialog öffnet sich, wenn Sie die Browse Taste rechts neben dem Textfeld drücken. Sie können das Einstellungsfenster auch für spätere Einstellungen vom Arbeitsfenster aus aufrufen. Die Einstellungen werden über die Programmlaufzeit hinaus gespeichert, sie müssen Sie also nur einmal vornehmen, wenn sich der Ordner nicht ändert.

Nachdem Sie den Ordner angegeben haben bestätigen Sie ihre Eingabe mit einem Klick auf OK.


Daraufhin wird das Arbeitsfenster des DDFCreators angezeigt.

Beschreibung

Das DDFCreator Arbeitsfenster

Abbildung 33.2:Hauptfenster des DDFCreators
Abbildung 33.2: Hauptfenster des DDFCreators


Die einzelnen Menüpunkte werden in den folgenden Unterkapiteln beschrieben. In der Abbildung 33.2 werden fertige DDFs für komplexere Geräte als Beispiel gezeigt.

Menu Datei:

In diesem Menu finden Sie Auswahlmöglichkeiten um:

  • Ein neues DDF zu erstellen
  • Ein vorhandenes DDF zu laden
  • Ein geöffnetes DDF zu speichern
  • Ein geöffnetes DDF zu schließen
  • DDFCreator zu beenden


Menu DDF Eigenschaften:

In diesem Menü können Sie die Basiseigenschaften eines DDFs einstellen. Dazu gehören:

  • Die DMX Kanäle des DDFs
  • Die DDF Informationen; also Hersteller, Name des Gerätes sowie den Autor und Version des DDFs
  • Das Layout des DDF-Menüs, also die Größe des Popup-Fensters.
  • Die DDF Procedures, also erweiterte Funktionen.
  • Ein Hilfetext, der z.B: die Einstellung des benötigten Gerätemodes erklärt.

Mehr zu den einzelnen Untermenus im Verlauf dieses Dokumentes.

Menu DDFCreator Einstellungen:

Hier öffnen Sie das Einstellungsfenster vom DDFCreator.


Menu Online:

Hier stehen ihnen folgende Möglichkeiten zur Verfügung:

  • DDFCreator Online Update

Menu ?

Hier erhalten Sie Informationen über DDFCreator.

Überblick zur DDF-Erstellung

In diesem Beispiel wird die Bedienung des DDFCreators erläutert. Als Beispiel dient ein DDF für einen Scheinwerfer. Dieser verfügt über einen DMX Kanal und soll stufenlos gedimmt werden.


Ein neues DDF erstellen

Um ein neues DDF zu erstellen klicken Sie im Menu Datei auf Neues DDF erstellen. Daraufhin wird ein neues DDF generiert, welches Ihnen auf dem Bildschirm angezeigt wird.

Das Arbeitsfenster sieht dann wie folgt aus:

Abbildung 33.3:Ansicht eines leeren DDFs
Abbildung 33.3: Ansicht eines leeren DDFs


Es enthält:

  • Platzhalter für Gerätenamen und DMX-Adresse. Die Werte werden durch DMXControl eingetragen, wenn das DDF in DMXControl verwendet wird.
  • Das Deviceimage. Stellt ein Bild in der Grafischen Ansicht von DMXControl dar. Dieses Bild kann geändert werden.
  • Das DDF. Der Bereich stellt die Größe des DDFs in DMXControl dar.


Alle Bedienelemente im DDFCreator sind mit einer ToolTip Funktion ausgestattet.

Wenn Sie also einmal nicht wissen, wozu ein Knopf da ist, halten Sie den Mauszeiger kurz darüber und sie können die Informationen des ToolTips lesen.

(Teilweise werden die ToolTips unten Links im Arbeitsfenster angezeigt)

Ein vorhandenes DDF bearbeiten

Das Bearbeiten eines vorhandenen DDFs funktioniert genauso, wie das Erstellen eines neuen DDFs.

Klicken Sie auf Datei -> DDF Laden und wählen Sie das zu ladende DDF aus.

Das DDF wird geprüft und erscheint dann auf der Arbeitsoberfläche.

Danach können Sie es ganz normal bearbeiten.

Kontextmenüs

Jedes Steuerelement, dass sich im DDF befindet verfügt über ein Kontextmenü. Dieses rufen Sie auf, indem Sie mit der rechten Maustaste auf das Steuerelement klicken.

Dieses sieht am Beispiel des Deviceimages wie folgt aus:

Abbildung 33.4:Kontextmenü des DeviceIcons
Abbildung 33.4: Kontextmenü des DeviceIcons


  • Mit der Rückgängig Funktion können Sie einen Schritt rückgängig machen. Dabei zeigt die Zahl in der Klammer die Anzahl der gespeicherten Schritte an.
  • Mit Einfügen können Sie neue Steuerelemente einfügen.
  • Mit Löschen können Sie ein vorhandenes Steuerelement löschen.
  • Mit Ausschneiden, Kopieren und Einfügen können Sie Steuerelemente wie in anderen Programmen bearbeiten.
  • Über Eigenschaften rufen Sie das Eigenschaftsfenster des aktuellen Steuerelements auf.

Grafische Elemente definieren

Das Deviceimage ändern

Um das Deviceimage oder dessen Position zu ändern müssen Sie als erstes das Eigenschaftsfenster des Deviceimage aufrufen. Dies geschieht entweder, indem Sie doppelt auf das Deviceimage klicken, oder über rechte Maustaste -> Eigenschaften. Sie können die Eigenschaftsfenster für andere Steuerelemente auf die gleiche Art und Weise aufrufen. DeviceName und DMX-Adresse haben allerdings kein Eigenschaftsfenster. Eine Abbildung des Deviceimage Fensters finden Sie hier.


In diesem Fenster können Sie alle Einstellungen des Deviceimage vornehmen. Auf der rechten Seite können Sie die Position und die Größe des Deviceimage enstellen. Sollten keine Werte für height und width eingetragen sein, wird jeweils der Standardwert von 32 verwendet.


Im Linken Teil befindet sich das aktuelle Deviceimage. Mit einem Doppelklick auf dieses öffnet sich ein weiteres Fenster indem sich eine Auflistung aller im Images Ordner enthaltenen Bilder befindet. Sie können das Bild durch markieren auswählen. Dabei wird immer das zuletzt angeklickte Bild übernommen wenn Sie auf OK klicken.


In diesem Beispiel wollen wir einen blauen Scheinwerfer steuern. Die Position und die Größe des Images wollen wir nicht ändern. Markieren Sie BLUE.gif in der Bildauswahl und klicken Sie sowohl in der Bildauswahl als auch im Deviceimage Eigenschaftsfenster auf OK. Die Fenster schließen sich und sie sehen wie das ausgewählte Deviceimage übernommen wurde.

Ein Steuerelement einfügen

Um den Scheinwerfer nun dimmen zu können fügen wir einen Schieberegler, auch Slider genannt ein. Dazu klicken Sie rechts auf eine freie Stelle im DDF und im Kontextmenü auf Einfügen -> Slider.

Daraufhin wird an der Stelle an der Sie rechts geklickt haben ein neuer Slider eingefügt.

Abbildung 33.5:Kontextmenü mit verschiedenen Optionen
Abbildung 33.5: Kontextmenü mit verschiedenen Optionen


Ihr DDF sollte nun ungefähr wiefolgt dargestellt werden:

Abbildung 33.6:DDF mit einem hinzugefügten Slider
Abbildung 33.6: DDF mit einem hinzugefügten Slider


Ein Steuerelement verschieben

Wahrscheinlich sitzt der Slider nicht genau dort wo er sitzen soll, deshalb verschieben wir ihn. Das Verschieben funktioniert bei allen anderen Steuerelementen genau gleich. Klicken Sie auf das Steuerelement. Es wird von einem Rahmen umzogen. Ziehen Sie das Steuerelement mit gedrückter Maustaste an die gewünschte Stelle.

Nachdem Sie den Slider an die richtige Stelle geschoben haben können Sie ihn noch in seiner Größe ändern.

Die Größe eines Steuerelementes ändern

Hierbei gibt es die gleichen Möglichkeiten wie beim Verschieben. Das Skalieren funktioniert bei allen Steuerelementen gleich.

Die Steuerelemente Options und Label können aber nicht skaliert werden.

Ein Steuerelement löschen

Falls Sie ein Steuerelement löschen wollten, gibt es zwei Möglichkeiten.

  • Per Maus löschen: Dazu klicken Sie rechts auf das Steuerelement und im Kontext Menu auf Löschen. Anschließend werden Sie gefragt, ob Sie wirklich löschen wollen. Bestätigen Sie die Frage mit JA. Das Steuerelement wird gelöscht.
  • Per Tastatur löschen: Klicken Sie dazu auf das Steuerelement, sodass er markiert ist. Drücken Sie nun auf der Tastatur die ENTF Taste. Das Steuerelement ist gelöscht.

Die Größe des Layouts ändern

Da wir nur den Slider als Bedienelement benötigen, ist das DDF viel zu groß. Gehen Sie über das Menu DDF-Eigenschaften in das Layout Fenster. Dort können Sie die Größe beliebig einstellen. Per druck auf OK werden die Einstellungen übernommen.

Abbildung 33.7:Menüeintrag DDF Eigenschaften
Abbildung 33.7: Menüeintrag DDF Eigenschaften


Abbildung 33.8:Einstellungen für das DDF-Layout
Abbildung 33.8: Einstellungen für das DDF-Layout


Alternativ können Sie auch einfach den Rahmen, der um das DDF gezogen ist mit der Maus anklicken und skalieren.

Nachdem Sie das alles gemacht haben, ist die Darstellung des DDFs schon fertig. Als nächstes müssen wir uns um die DMX-Eigenschaften kümmern.

DMX Kanäle festlegen

Abbildung 33.9:Übersicht über die vom DDF verwendeten Kanäle
Abbildung 33.9: Übersicht über die vom DDF verwendeten Kanäle


Jedes DMX Gerät hat eine bestimmte Anzahl von belegten DMX Kanälen. Diese müssen in das DDF eingetragen werden. Der Scheinwerfer in diesem Beispiel hat nur einen Kanal. Hochwertige Geräte können 16 oder mehr Kanäle haben.

Über das Menü DDF Eigenschaften kommen Sie in das Untermenu DMX Kanäle (siehe Abbildung 33.9). Öffnen Sie dieses Fenster. Wie Sie sehen ist bereits ein DMX Kanal angelegt. Für dieses Beispiel benötigen wir keine zusätzlichen Kanäle. Falls Sie für ein anderes zusätzliche DDF DMX-Kanäle anlegen müssen, klicken Sie auf Neu und legen dadurch neue Kanäle an. Klicken Sie doppelt in die Spalten und tragen Sie ihre Werte ein. Achten Sie darauf, dass Sie die Kanäle in der richtigen Reihenfolge eintragen. Dabei verschiebt sich alles um eine Zahl. Das bedeutet, der erste Kanal des Gerätes ist im DDF als Kanal 0 vorgegeben, der siebte ist demnach Kanal 6, usw. DDFCreator kontrolliert beim Druck auf OK die eingetragenen Werte auf ihre Korrektheit, wobei ein korrekter Wert natürlich nicht immer für das entsprechende DDF richtig ist. Sollten Sie aus versehen einen falschen Wert eingetragen haben, werden Sie bei Druck auf OK, auf den Fehler hingewiesen, und die fehlerhafte Zelle wird markiert. Wenn Sie einen Kanal löschen wollen, markieren Sie die Kanalnummer in der channel Spalte und drücken Sie auf Löschen. Dabei werden die Kanalnummern automatisch neu durchnummeriert.

TYPE Konfiguration

Unter "type" kann man dem Kanal bestimmte Funtionen zuordnen! Alle "types" müssen klein geschrieben werden!!!

  • 1. pan ---> Pankanal
  • 2. tilt --->  Tiltkanal
  • 3. panfine ---> 2ter Pankanal, erforderlich bei Geräten mit 16bit.
  • 4. tiltfine ---> 2ter Tiltkanal, erforderlich bei Geräten mit 16bit.
  • 5. gobo ---> Gobokanal, erforderlich bei globalen Gobolisten.
  • 6. color ---> Colorkanal, erforderlich bei globalen Colorlisten.
  • 7. dimmer ---> Dimmer-, Shutter-, ON/OFF-Kanal. mit Hilfe dieses Kanals ist es möglich die "blackout-Funktion" in DMXC zu nutzen.
  • 8. r ---> Rot - Wichtig für "HAL" ab 2.11 (darstellung der Farbe in der Grafischen Bühnenansicht)
  • 9. g ---> Grün - Wichtig für "HAL" ab 2.11 (darstellung der Farbe in der Grafischen Bühnenansicht)
  • 10. b ---> Blau - Wichtig für "HAL" ab 2.11 (darstellung der Farbe in der Grafischen Bühnenansicht)

Folgende types machen Sinn haben aber bis jetzt keine zugeordnete Funktion

  1. w ---> Weiß
  2. a ---> Amber
  3. c ---> Cyan
  4. m ---> Magenta
  5. y ---> Gelb

Da kein weiterer Kanal als der bereits vorhandene benötigt wird, schliessen wir das Fenster.

Informationen über das DDF eintragen

Abbildung 33.10:Einstellungsfenster für das DDF
Abbildung 33.10: Einstellungsfenster für das DDF


Als nächstes sollten Sie im Informationsbereich des DDFs Daten über den Autor und das Gerät hinterlegen. Dazu öffnen Sie bitte das Fenster DDF Informationen (siehe Abbildung 33.10). Im darauffolgenden Fenster können Sie alle Informationen eingeben. Dabei ist name der Name des Gerätes, author sind Sie, und vendor ist der Hersteller des Gerätes.

Als nächstes muss der Slider eingestellt werden. Öffnen Sie dazu wie unter 5.3 beschrieben das Eigenschaftsfenster des Sliders (per Doppelklick oder über Kontext Menu). Es öffnet sich das Eigenschaftsfenster (siehe Abbildung 33.12).

Um das DDF fertig zu machen, müssen wir nun dem Slider noch einen Kanal zuweisen. Dazu tragen Sie unter channel eine 0 ein, weil der Slider sich auf Kanal 0 beziehen soll. Danach noch den endvalue auf 255 anheben und fertig. Nachdem Sie auf OK gedrückt haben, ist das DDF fertig. Über Datei -> DDF Speichern können Sie das DDF in einem Ordner ihrer Wahl speichern.

Das fertige DDF sollte ungefähr so aussehen:

Abbildung 33.11:Fertiges DDF
Abbildung 33.11: Fertiges DDF


Die Eigenschaftsfenster

Jedes Steuerelement (bis auf DeviceName und DMX-Adresse) verfügen über ein Eigenschaftsfenster. In diesem Fenster können alle Eigenschaften des Elementes eingestellt werden. Dabei verfügt DDFCreator über eine Fehlererkennung, welche die meisten Fehler findet und durch eine Meldung anzeigt. Im Folgenden werden die Eigenschaftsfenster der einzelnen Steuerelemente dargestellt und auf Besonderheiten hingewiesen.

Allgemeine Eigenschaften

Die Eigenschaften top, left, height und width beschreiben die Positionierung und Größe des Elementes. Alle Bedienelemente in DDFCreator sind mit einer ToolTip Funktion ausgestattet. Wenn Sie also einmal nicht wissen, wozu ein Attribut da ist, halten Sie den Mauszeiger kurz darüber, und sie können die Informationen des ToolTips lesen.


Das Eigenschaftsfenster des Sliders

Abbildung 33.12:Eigenschaften des Sliders
Abbildung 33.12: Eigenschaften des Sliders


Das Eigenschaftsfenster ist sehr einfach aufgebaut. Für jede Eigenschaft des Sliders gibt es ein Textfeld, in das Sie Zahlenwerte oder Zeichenketten (Strings) eintragen können.

Das Eigenschaftsfenster des Commands

Abbildung 33.13:Eigenschaften des Commands
Abbildung 33.13: Eigenschaften des Commands


Im Commandfenster können Sie wie beim Slider die gewünschten Werte einfach eintragen. Eine Besonderheit ist, dass Sie die Sequenz Felder auch mit einem Wert aus der in DDFCreator enthaltenen Bibliothek füllen können. Klicken Sie dazu rechts auf das Sequenzfeld, und dann auf Code aus der Bibliothek einfügen oder auf den Button neben dem Feld. Mehr über die Codebibliothek von DDFCreator unter 6.2. Zusätzlich kann der Button noch gefärbt und mit einem Icon versehen werden. Um die Farbe oder ein Icon auszuwählen einfach doppelt auf die entsprechende Fläche klicken. Zum entfernen der Farbe bzw. des Icons einfach doppelt Rechts auf die Fläche klicken.

Das Eigenschaftsfenster des Deviceimages

Abbildung 33.14:Eigenschaften des DeviceImages
Abbildung 33.14: Eigenschaften des DeviceImages


In diesem Fenster können Sie das Deviceimage auswählen. Um das Bild zu ändern, einfach doppelt darauf klicken und im folgenden Fenster das neue Bild auswählen. Im Auswahlfenster werden alle GIFs angezeigt, die im Images Ordner vorhanden sind. Sie können also einfach neue GIFs mit den Maßen 32 x 32 Pixel in den Ordner kopieren, und diese werden von DDFCreator beim nächsten Aufruf automatisch erkannt.

Das Eigenschaftsfenster des OnOff

Abbildung 33.15:Eigenschaften des OnOff
Abbildung 33.15: Eigenschaften des OnOff


Das OnOff Fenster ist sehr intuitiv gehalten. Sequenzen können über die Bibliothek eingefügt werden, dazu rechts auf das Textfeld klicken oder den Button benutzen. Mehr über die Codebibliothek von DDFCreator unter 6.2. Beim OnOff ist es nicht erlaubt, dass sowohl in on- und offvalue etwas steht, sowie in on und offsequence. Deshalb werden die jeweils anderen Textfelder deaktiviert, sobald in die anderen etwas eingetragen wird. Das Hinzufügen und Entfernen von Farbe und Icon ist identisch zum Command.

Das Eigenschaftsfenster des Dropdown

Abbildung 33.16:Eigenschaften des Dropdowns
Abbildung 33.16: Eigenschaften des Dropdowns


In der Liste auf der linken Seite können Sie die einzelnen Items des Dropdowns mit den dazugehörigen Werten eintragen. Über die Taste Neu können sie neue Items anlegen. Klicken Sie auf einen Namen oder einen Wert um diesen zu ändern. Mit Löschen können sie einen Eintrag aus der Liste löschen. Über Hoch und Runter können Sie die Reihenfolge der Einträge verändern. Jedes Item kann mit einer Farbe oder einem Icon versehen werden. Dies funktioniert analog zum Command. Sollte wie in diesem Beispiel eine Farbe und ein Icon vergeben sein, wird nur das Icon angezeigt.

Das Eigenschaftsfenster des Label

Abbildung 33.17:Eigenschaften des Labels
Abbildung 33.17: Eigenschaften des Labels


Das Eigenschaftsfenster des Labels ist sehr übersichtlich. Für jede Eigenschaft gibt es ein Textfeld zum Eintragen. Die Breite des Labels wird automatisch durch die Textlänge ermittelt.

Das Eigenschaftsfenster des Options

Abbildung 33.18:Eigenschaften der Options
Abbildung 33.18: Eigenschaften der Options


Das Options Fenster ist zweigeteilt, in einen allgemeinen Bereich, und in einen spezifischen Bereich, weil das Options aus zwei Teilen besteht:

  • einem Container in dem sich alle Radiobuttons befinden, und
  • die Radiobuttons selber.

Deshalb ist der linke Teil auch immer der gleiche, egal auf welchen Radiobutton geklickt wurde, da sich alle auf den gleichen Container beziehen. Der rechte Teil hingegen beschreibt den Radiobutton, der gerade ausgewählt wurde. Die Position des spezifischen Buttons ist relativ zum Container. Das bedeutet, die Koordinaten des Buttons im DDF wären in diesem Beispiel top=173 und Left=108. Mehr zu der Besonderheit der Options und deren Bearbeitung unter Abschnitt 4.

Das Eigenschaftsfenster des Position

Abbildung 33.19:Eigenschaften des Position-Elements
Abbildung 33.19: Eigenschaften des Position-Elements


Das Eigenschaftsfenster des Positions ist selbsterklärend.

Hinweis: Das Position-Element ist automatisch an die Kanäle Pan und Tilt gekoppelt. Daher muß hier kein "channel" zugewiesen werden.

Das Eigenschaftsfenster des Colorpickers

Abbildung 33.20:Eigenschaften des Colorpickers
Abbildung 33.20: Eigenschaften des Colorpickers


Das Colorpicker Steuerelement ermöglicht es über drei DMX Kanäle bei RGB Geräten jede beliebige Farbe einzustellen. Diese drei Kanäle werden in den Feldern channel 1 – 3 hinterlegt. Mode kann entweder den Wert „rgb“ oder „cmy“ haben, je nach dem ob das Gerät RGB oder CMY Farbmischung hat. Die Eingabefelder für Position und Größe sind in ihrer Funktion identisch mit den anderen Controls.

Das Line Steuerelement

Das Line Element wird als Linie angezeigt, und kann ganz normal skaliert werden. Ein Doppelklick auf die Linie dreht diese um 90°.


Was Sie über das Bearbeiten von Options Elementen wissen sollten

Options Elemente verhalten sich anders als andere Elemente. Deshalb wird in diesem Teil besonders auf die spezifischen Eigenschaften eingegangen. Dabei bezeichnet das Options das gesamte Element, mit allen Symbolen und dem Container. Ein Option ist ein einzelnes Element im Container.


Das Einfügen von Options

Options Elemente bestehen immer aus mehr als einem Symbol. Deshalb wird mit dem Erstellen des ersten Elementes immer ein Container mit angelegt. In diesen werden die Elemente eingefügt. In Abbildung 33.24 ist gezeigt, wie ein Option neu eingefügt wurde. Um nun ein weiteres Option zu diesem hinzuzufügen, klicken Sie rechts auf das erstellte und auf Einfügen -> Options, daraufhin wird zu dem einen, ein zweites hinzugefügt. Für ein drittes und viertes usw. funktioniert es genau gleich. Die Containergröße passt sich automatisch an die Anzahl und die Position der Option an.

Abbildung 33.21:Ein Options-Steuerelement
Abbildung 33.21: Ein Options-Steuerelement
Abbildung 33.22:Options mit zwei Elementen
Abbildung 33.22: Options mit zwei Elementen


Wenn sie anstelle von dem erstellten Options auf eine leere Stelle im DDF klicken, und dort ein Options einfügen, erstellen Sie ein zweites komplett unabhängiges (siehe Abbildung 33.26).

Abbildung 33.23:Ansicht mit zwei Options
Abbildung 33.23: Ansicht mit zwei Options


Die Sache mit dem Container

Das Options Element besteht aus einem Container und den einzelnen Option Elementen.

Abbildung 33.24:Options mit mehreren Elementen
Abbildung 33.24: Options mit mehreren Elementen


Der Container ist normalerweise unsichtbar, aber nicht transparent, das bedeutet, dass andere Steuerelemente durch den Container verdeckt werden. Deshalb ist es wichtig darauf zu achten, dass der Container nur so klein wie möglich ist. In Abbildung 28 ist zu sehen, das obwohl nur drei Option Elemente enthalten sind, der Container eine große Fläche einnimmt.

Abbildung 33.25:Ein Options-Menü verdeckt ein anderes
Abbildung 33.25: Ein Options-Menü verdeckt ein anderes


In Abbildung 33.25 sehen sie, wie das Label durch den Container verdeckt wird. In DMXControl ist das genauso.

Options bearbeiten

Da ein Options Element aus einem Container und den einzelnen Option Elementen besteht, gibt es zwei Möglichkeiten ein Options zu bearbeiten.

  • Der gesamte Container mit allen Elementen wird bearbeitet
  • Ein einzelnes Option wird bearbeitet.

Da Option Elemente sich nicht skalieren lassen, und sich die Größe des Containers automatisch auf den kleinst möglichen Wert einstellt, ist ein Skalieren nicht möglich. Daher stehen nur Verschieben und Löschen als Bearbeitungsmöglichkeiten zur Verfügung.

Normalerweise markieren Sie beim Anklicken eines einzelnen Option den gesamten Container. Um nun ein einzelnes Option im Container anzuwählen, drücken sie die # Taste. In der Statusleiste von DDFCreator wird ihnen angezeigt, dass nun EINZELNES OPTION BEARBEITEN AKTIVIERT ist. Mit einem erneuten Druck auf # wechseln Sie wieder in den globalen Modus. Die Aktivierung der # Option hat keinen Einfluss auf die Bearbeitung von anderen Steuerelementen.

Das gesamte Options verschieben

Das ist die Standardeinstellung. Klicken sie auf ein beliebiges Option, wird der komplette Container markiert wird. Verschieben sie nun wie in 3.4.3 beschrieben das Element. Sie werden sehen, dass sich der gesamte Container mit allen enthaltenen Option Elementen verschiebt.

Ein einzelnes Option verschieben

Drücken Sie # um den Bearbeitungsmodus umzuschalten. Markieren Sie wie gewohnt das zu bearbeitende Element, und verschieben Sie es wie in 3.4.3 beschrieben. Der Container passt sich automatisch an.

Das gesamte Options löschen

Markieren Sie den gesamten Container, falls erforderlich vorher # drücken, um wieder in den normalen Bearbeitungsmodus zu schalten. Löschen Sie das Element wie unter 3.4.5 beschrieben.

Ein einzelnes Option löschen

Schalten Sie per # den Bearbeitungsmodus um. Markieren Sie das zu löschende Option Element. Löschen Sie es wie in 3.4.5 beschrieben. Sollte das Option Element das letzte im Container enthaltene Element sein wird der Container automatisch mitgelöscht.


Code und Initsequence im DDF eintragen

Überblick

Um komplexere Funktionen im DDF zu realisieren, besteht die Möglichkeit sog. Procedures zu programmieren, die beim Verändern eines DMX Kanals oder eines Steuerelementes aufgerufen werden. Eine Beschreibung der Programmiersprache finden Sie im DDF-Tutorial auf der Homepage. Um diese Procedures im Editor zu hinterlegen, gibt es das DDF Procedures Fenster. In diesem Fenster kann auch die Initsequence eingegeben werden. Öffnen Sie das Fenster über DDF-Eigenschaften -> DDF Procedures.

Abbildung 33.26:Ansicht des Proceduren-Fensters
Abbildung 33.26: Ansicht des Proceduren-Fensters


Auf der linken Seite sehen Sie eine Liste der vorhandenen Procedures. Mit Neu fügen Sie ein neues Procedure hinzu. Mit Löschen entfernen Sie ein vorhandenes. Auf der rechten Seite können Sie im Codefenster den Procedurecode eintragen, oder über Rechtsklick auf das Fenster aus der Codebibliothek holen. Wenn Sie Änderungen im Code vornehmen, werden diese zwischen gespeichert. Sie können also ein Procedure bearbeiten und dann ein anderes auswählen und dieses ändern. Erst wenn Sie auf OK drücken werden die Änderungen für alle Procedures ins DDF geschrieben. Genauso ist es mit der Initsequence. Sie können diese Manuell eintragen oder per Rechtsklick über die Bibliothek holen. Mehr über die Bibliothek in 6.2.


Die Codebibliothek

Abbildung 33.27:Die Code-Bibliothek
Abbildung 33.27: Die Code-Bibliothek


Ein sehr nützliches Feature in DDFCreator ist eine vorhandene leicht erweiterbare Codebibliothek. Diese ermöglicht es Sequences und Procedures auf Abruf schnell einzufügen, und sich so die Programmierung und Fehler zu vermeiden. Die Elemente aus der Bibliothek sind allgemeine Codebausteine, die auf jeden Fall noch an das entsprechende DDF angepasst werden müssen. Die Bibliothek enthält verschiedenen Procedures, die oft in ähnlicher Art und Weise verwendet werden, und von daher leicht anzupassen sind. Genauso ermöglicht es die Bibliothek eigenen Code einzuspeichern, um diesen zukünftig bei DDFs zu nutzen.

Die Codebibliothek aufrufen

Sie können die Codebibliothek von jedem Textfeld aus aufrufen, in das Sie eine Sequence oder ein Procedure einfügen können, indem Sie rechts auf das Feld klicken und dann im folgenden Kontextmenu auf Code aus der Bibliotek einfügen.

Eigene Bausteine einfügen

Die Bausteine werden in der Datei code.xcq im DDFCreator Verzeichnis gespeichert. Diese Datei kann von ihnen nach belieben geändert werden, um neue Codebausteine hinzuzufügen. Die Bibliothek unterstützt mehrsprachige Kommentare. Dazu wird einfach für jede Sprache ein eigener <description> Block angelegt. Das Attribut lang entscheidet welche Sprache es ist. Dabei ist der Aufbau wie folgt:

<library>
  <procedure name=“Hier steht der Name des Procedures“>
      
	Hier kommt der Code rein, auch Mehrzeilig
     
     <description lang=“german“>
	Hier kommt der Kommentar oder die Beschreibung des Bausteins rein
     </description>
  </procedure>
  <sequence name=“Hier steht der Name der Sequenz“>
      
	Hier kommt der Code rein, auch Mehrzeilig
     
     <description lang=“german“>
	Hier kommt der Kommentar oder die Beschreibung des Bausteins rein
     </description>
     <description lang=“english“>
	Here is the English description stored.
     </description>
  </sequence>
</library>

Ein Baustein besteht immer aus einem äußeren Tag (procedure oder sequence) der beschreibt, ob es sich bei dem Baustein um ein Procedure oder um eine Sequence handelt. Der äußere Tag enthält dann zwei innere Tags, einen für den Code, den anderen für die Beschreibung. Die Reihenfolge der Bausteine ist egal, DDFCreator wählt je nachdem, ob ein Procedure oder eine Sequence eingefügt werden soll die entsprechenden Elemente aus. Natürlich muss erst ein Baustein abgeschlossen sein, bevor der nächste anfangen darf, wie folgendes falsche Beispiel zeigt:

<library>
  <procedure name=“Hier steht der Name des Procedures“>
      
	Hier kommt der Code rein, auch Mehrzeilig
     
  <sequence name=“Hier steht der Name der Sequenz“>
      
	Hier kommt der Code rein, auch Mehrzeilig
     
     <description lang=“german“>
	Hier kommt der Kommentar oder die Beschreibung des Bausteins rein
     </description>
  </sequence>
     <description lang=“german“>
	Hier kommt der Kommentar oder die Beschreibung des Bausteins rein
     </description>
  </procedure>
</library>

Nach einer Änderung von code.xcq steht nach einem Neustart von DDFCreator der Baustein ganz normal zur Verfügung. Achten Sie darauf, vor einer Aktualisierung von DDFCreator ihre code.xcq zu sichern, da diese sonst überschrieben werden kann.


Online Funktionen

DDF-Upload Funktion

Mit dieser Funktion wird das aktuell angewählte DDF an den DMXControl Server geschickt. Es wird direkt auf die Homepage geladen und steht der Nutzergemeinde sofort zur Verfügung. Sollte ein DDF von ihrem Gerät bereits verfügbar sein, werden Sie darauf hingewiesen.

Online Update Funktion

Seit Version 1.1 steht eine Online Update Funktion zur Verfügung. Mit dieser Funktion aktualisiert sich DDFCreator automatisch über das Internet. Wenn Sie auf Online Update klicken, testet DDF-Editor die Verbindung zum DMXControl Server. Danach werden die lokalen Dateien mit denen auf dem Server verglichen. Sollten neue Dateien gefunden worden sein, wird ihnen der Download angeboten. Mit den Haken in den Checkboxen vor den Dateinamen können Sie anwählen, welche Dateien sie herunterladen wollen. Die lokalen Dateien werden ohne weiteres Nachfragen überschrieben. Seien sie also vorsichtig, wenn Sie der Codebibliothek eigenen Code hinzugefügt haben, da dieser beim Updaten überschrieben wird. Sichern Sie ihre eigene Code Datei deshalb vor dem Update. In Version 1.2 von DDFCreator ist eine Merge Funktion geplant, welche die neue Code Bibliothek und die eigene auf der Festplatte vereint, dadurch entfällt das sichern.

Sprache

Die Sprachdateien

Im Unterordner Language von DDFCreator gibt es Sprachdateien für DDFCreator, für jede Sprache eine. Dabei ist der Dateiname gleichzeitig die Sprache. Falls Sie uns helfen möchten und den Editor in eine neue Sprache übersetzen wollen gehen Sie wie folgt vor.

  • Kopieren Sie die Ausgangsdatei (also z.B. german.xcl) und benennen Sie die neue Datei in den Namen der Sprache (z.B. spanisch.xcl)
  • Öffnen Sie die neue Datei. Die Sprachdatei selber ist wieder ein XML File. Zwischen zwei Tags steht immer der Text. Übersetzten Sie einfach alle angegebenen Strings in die neue Sprache. Ändern Sie den Namen der Sprache ganz oben im File ab. Speichern Sie die Datei.
  • Nun können Sie die neue Sprache in DDFCreator einstellen. Nach einem Neustart arbeitet DDFCreator mit der neuen Spracheinstellung.
  • Bitte schicken Sie uns die neue Sprachdatei, damit wir diese der ganzen Nutzergemeinde zugänglich machen können.

Tipps/Support Funktionen

Die Tastaturkürzel

Taste #

  1. Schaltet den Bearbeitungsmodus für das Options Element um. Mit dieser Taste bestimmen Sie, ob Sie das gesamte Options oder nur ein einzelnes Option bearbeiten wollen.

STRG + Z

Mit dieser Tastenkombination machen Sie den letzten Schritt rückgängig. Dies wird über die Rückgängigfunktion von DDFCreator durchgeführt. Mehr über die Rückgängigfunktion in 3.8.

Taste Umschalt, auch Shift oder Großschreibtaste

Mit dieser Taste aktivieren Sie die Mehrfachauswahl, Sie können nun wie im Windows Explorer mehrere Elemente markieren und diese gleichzeitig verschieben, löschen, ausschneiden und kopieren.

Taste ENTF

Über die ENTF Taste können Sie das markierte Element, bzw. die markierten Elemente löschen.

STRG + C

Kopiert die markierten Steuerelemente in die Zwischenablage.

STRG + X

Kopiert die markierten Steuerelemente in die Zwischenablage, und entfernt diese aus dem DDF.

STRG + V

Fügt kopierte oder ausgeschnittene Steuerelemente wieder ein.

Die Rückgängig Funktion

Die Rückgängig Funktion erlaubt es ihnen eine Aktion rückgängig zu machen. Aktionen sind:

  • Ein neues Steuerelement erstellen
  • Ein vorhandenes Steuerelement verschieben (auch mehrere)
  • Ein Steuerelement skalieren
  • Ein Steuerelement löschen

Nicht rückgängig gemacht werden Änderungen die über die Eigenschaftsfenster vorgenommen wurden. Wenn Sie also die Kanalnummer für einen Slider über das Eigenschaftsfenster ändern wird dies durch die Rückgängig Funktion nicht wieder zurückgesetzt.

Die automatische DDF Überprüfung

Wenn Sie ein neues DDF laden wird in einem Ladebalken angezeigt, dass das DDF überprüft wird. In diesem Balken erhalten Sie Informationen, welcher Knoten gerade überprüft wird. Nach der Überprüfung wird ihnen ein Fenster angezeigt, in welchem die gefundenen Fehler dargestellt werden. Hier können Sie auswählen, welche Fehler behoben werden sollen.

Abbildung 33.28:Prüfung des DDFs auf Fehler
Abbildung 33.28: Prüfung des DDFs auf Fehler


Dabei werden in einer Baumansicht die Knoten angezeigt, und welche Attribute fehlerhaft sind. Sollten keine Attribute angezeigt werden, ist der Knoten selber falsch. Im rechten Bereich wird der Fehler beschrieben, und der XML Code angezeigt. Im unteren Bereich kann ausgewählt werden, wie die Reparatur durchgeführt werden soll.

Abbildung 33.29:Fehler in DDF gefunden
Abbildung 33.29: Fehler in DDF gefunden


Links und Referenzen


Tutorial: DDF mit DDFCreator erzeugen

 

Arrow back.png DDF
Beamertool Plugin Arrow forw.png
Inhaltsverzeichnis
Meine Werkzeuge
Namensräume

Varianten
Aktionen
Navigation
DMXControl 2
DMXControl 3
Tipps und Tricks
Hardware
Berichte
In anderen Sprachen
Werkzeuge