MadMaxOne Plugin DMXC2

Aus DMXCWiki
Wechseln zu: Navigation, Suche

Books.png MadMaxOne Plugin DMXC2
Arrow back.png Beamertool Plugin
OSC Receiver Plugin Arrow forw.png
Inhaltsverzeichnis

 

Inhaltsverzeichnis

Überblick

Das MadMaxOne-Plugin für DMXControl dient der Steuerung von Matrizen aus RGB-fähigen “Lampen”. Beispiele hierfür sind von unten beleuchtete Tanzböden oder mit LED-Panels ausgestattete Wände. Das Plugin ist ein aktives Tool, das heißt, es hat eigene Effekte und Szenen und man muss nicht mit den Szenen/Effekten von DMXControl arbeiten um dynamische Effekte zu bekommen. Diese Plugin ersetzt das alte Matrix-Plugin.

MadMaxOne-Plugin

Beschreibung

Die Ansteuerung des Plugins von DMXControl erfolgt durch Befehle. Des weiteren kann auch das interne oder externe MxSim-Plugin für DMXControl zur Ausgabe genutzt werden. Dieses simuliert eine Matrix mit Hilfe eines Beamers.

Installation des Plugins

Für die Installation ist nur das Plugin herunter zu laden (siehe Links) und im „Plugins“-Verzeichnis von DMXControl zu speichern. Sollte das alte Matrix-Plugin schon installiert sein, ist es sicherer dieses erst zu entfernen (matrix.dll)

Vor der ersten Benutzung muss das Plugin konfiguriert werden (s. nächstes Kapitel).

nur für DMXControl 2.11 und älter:

Da das Plugin Steuerelemente verwendet, die nicht zum Windows-Standard gehören und auch nicht von den älteren DMX-Control-Versionen installiert werden, ist es nötig diese vorher zu installieren. Dazu ist folgendes Programm downzuloaden und auszuführen:

vcslider.exe

Konfiguration des Plugins

Das Plugin muss vor der Benutzung konfiguriert werden. Hier werden die Dimension der Matrix festgelegt und dann für jeden „Punkt“ der Matrix die DMX-Kanäle für Rot, Grün und Blau festgelegt. Schon konfigurierte Punkte werden weiß dargestellt, während noch nicht konfigurierte Punkt grau sind. Mittels der Buttons „Load“ und „Save“ können Konfigurationen gelesen und gespeichert werden.

DMXC2 Manual Matrix conf.gif

Wenn man die Konfiguration des Plugins mit dem Namen des aktuellen DMXControl-Projekts speichert, dann wird diese Konfiguration beim Start von DMXControl automatisch gelesen, so dass bei allen weiteren Starts von DMXControl das Plugin automatisch konfiguriert wird und sofort einsatzbereit ist. Für die Konfiguration einer Matrix, die aus Geräten besteht, wo jede Reihe oder Spalte durch ein Gerät realisiert ist, gibt es die Möglichkeit das Plugin mit der „Fast Configuration“-Methode zu konfigurieren. Dabei werden für jeden Punkt ab der Basisadresse die DMX-Kanäle zugewiesen, wobei unterschiedliche Anordnungen der Geräte ausgewählt werden können.

DMXC2 Manual Matrix QuickConf.jpg

Zusätzlich kann man ein DDF-File generieren, das die Kanäle der Matrix belegt. Dieses ist für den Betrieb des Plugins nicht wichtig, belegt aber innerhalb von DMXControl die Kanäle und macht das Gerät auch in der graphischen Ansicht verfügbar. Für ein besseres Zusammenspiel von MadMaxOne und DMXControl sollte man dieses DDF erstellen und im Devices-Ordner von DMXControl ablegen. Danach ist es natürlich in der graphischen Ansicht, bzw. im Gerätefenster, dem Projekt hinzuzufügen.


 Wichtiger Hinweis DMXControl unterstützt zurzeit nur 1024 Kanäle, daher muss für die DMX-Ausgabe der Wert für Universe auf 1 oder 2 stehen. Höhere Werte für Universe machen im Moment nur Sinn, wenn man einfach nur testen will oder den eingebauten MatrixSimulator zur Anzeige über einen Beamer nutzen will. Hier gilt die Beschränkung auf 1024 Kanäle nicht. Bei der Benutzung des internen MxSim-Plugins sollte das „alte“ externe MxSim-Plugin deaktiviert werden.


Das Plugin unterstützt in der jetzigen Version Matrizen bis zur Größe von 50x50 Punkten. Diese würden alleine für RGB-Werte 7500 DMX-Kanäle belegen, daher ist das Plugin für die Unterstützung von 16 DMX-Universen ausgelegt (~ 8192 Kanälen). Da DMXControl aber in der aktuellen Version nur 1024 Kanäle ausgibt, werden bei eingeschaltetem DMX-Schalter nur die Kanäle 1-1024 an DMXControl übertragen.

Neu ab der Version 2.12 sind die Dimmerkurven. Damit diese zur Verfügung stehen, muss die Datei dimmercurve.csv in das Plugins-Verzeichnis von DMXControl kopiert werden. Zur Verfügung stehen 4 Kurven (Linear, LED1, LED2, LED3), die die Ausgabe der DMX-Werte entsprechend unten stehendem Diagramm ändert.

DMXC2 Manual Matrix dimmercurves.jpg

Bedienelemente

DMXC2 Manual MadMaxOne2.jpg

Sofern im Projektverzeichnis eine Datei mit gespeicherten Matrix-Effekten vorhanden ist, die den Namen <ProjektName>.MadMax hat, wird diese automatisch beim Start des Plugins geladen (ab V2.12 des Plugins).

Das Plugin zeigt im Hauptfenster drei Matrizen, von denen zwei (rechts und links) jeweils einen „Effekt“ ausführen. Die dritte Matrix (Mitte) enthält die Ausgabematrix. Das Bild dieser Matrix wird bestimmt durch die beiden anderen Matrizen, sowie den Fademode und die Position des Faders. Beim FadeMode gibt es elf verschiedene Modi:

1. CrossFade - Dies ist ein direktes Überblenden zwischen Matrix A und Matrix B
2. BlackFade - Dabei wird beim Überblendvorgang die eine Matrix erst schwarz gefärbt und dann die andere eingeblendet.
3. ColorFade - Diese Überblendvorgänge sind ähnlich wie der BlackFade, nur dass hierbei statt schwarz eine beliebige andere Farbe gewählt werden kann. Ausgewählt wird diese Farbe durch einen Klick auf das (hier schwarze) Kästchen unter der Fadetime.
4. Random - Hierbei wird die Matrix durch das Setzen von Zufallspunkten übergeblendet
5. Flow Down – wie wenn die zweite Matrix wie Farbe von oben herunter läuft
6. Fill Up – wie Flow Down, nur kommt die Matrix von unten
7.- 10. Scroll… - Überblenden durch schrittweises Überschreiben der alten Matrix aus verschiedenen Richtungen
11. Add – dieser Fade-Effekt addiert die DMX-Werte beider Seiten wie anhand folgender Graphik zu sehen ist. Dies ist besonders sinnvoll, wenn man zum Beispiel einen weißen Tickereffekt in einen anderen Effekt einblenden möchte.

Add

12. Overlay - dieser Fade-Effekt ist dem Add-Mode sehr ähnlich. Es werden jedoch nur Punkte der Matrix mit Werten aus der anderen Seite hinzugefügt, wo auf der Hauptseite der Punkt schwarz ist. Dieser Fade hat seinen Hauptzweck ebenfalls im Zusammenspiel mit dem Ticker-Effekt, aber auch Kaleidoskop und Beam-Show sind hier gut für geeignet.

Mit dem Fader kann jeder Fadezustand manuell eingestellt werden. Ebenso sind mit den Buttons |< und >| die Matrizen rechts und links direkt anwählbar. Mit dem < und dem > Button wird ein Fade-Vorgang gestartet, der automatisch von A -> B, bzw. B -> A überblendet. Die Dauer dieses Vorgangs kann man im Feld „Time :“ einstellen. Im unteren Bereich des Fensters befinden sich die Buttons "Save" und "Load". Hiermit kann eine komplette Einstellung des Programms geladen bzw. gespeichert werden. Dabei werden folgende Sachen gespeichert:

• Die Stellung des Faders
• Die Daten aller Speicherplätze (Memory A und Memory B)
• Der gerade aktive Speicherplatz (A und B getrennt)
• Die Daten aller Fade-Speicherplätze
• Der gerade aktive Fade-Speicherplatz

Nicht gespeichert werden hier die Konfigurationsdaten des Plugins. Dies geschieht in der Plugin-Konfiguration.

Für die linke und die rechte Matrix können beliebig viele Speicherplätze erstellt werden. Mit dem + wird ein Effekt hinzugefügt und mit x wieder entfernt. Diese werden einfach durch Anklicken aktiviert. Mit den Buttons O-> und ->O kann man den gerade aktiven Effekt in eine Zwischenablage kopieren, bzw. den Effekt aus der Zwischenablage auf dem geraden aktiven Speicherplatz einfügen. Die Buttons "hoch" und "runter" dienen dem Sortieren der Speicherplätze. Über die Auswahlbox unter den Speicherplätzen kann der Typ des Effekts festgelegt werden. Dieser kann dann mit dem Edit-Button eingestellt werden. Die einzelnen Effekt-Typen werden später einzeln beschrieben. Mit dem Clear-Button wird ein Effekt auf den Typ „Color“ gesetzt und als Farbe schwarz gewählt. Mit der Checkbox „MxSim“ wird der interne Matrixsimulator aktiviert. Ganz unten links im Fenster, ist die Checkbox „DMX“. Nur wenn diese aktiviert ist sendet das Plugin auch Werte an DMXControl.


 Wichtiger Hinweis Da das Plugin aus Performancegründen nur die Kanäle sendet, die sich geändert haben, sollten vor Start des Plugins alle Geräte in Betrieb sein. Sollten während des Betriebs die theorethische Ausgabe (Darstellung in MadMaxOne) nicht mit der tatsächlichen Ausgabe übereinstimmen, hilft es einmal die Matrix schwarz und dann wieder weiß zu machen. Dabei wird garantiert jeder Kanal gesendet, so dass die Ausgaben wieder identisch sind.


Effekttypen

Hier ist eine Übersicht der verfügbaren Effekttypen (Editor & Ausgabe):

  • Color -> einfach Farbe

Konfiguration ColorEffekt

  • Gradient -> Farbverlauf

Konfiguration Gradient-Effekt

  • Paint -> von Hand gemalt

Konfiguration Picture-Effekt

  • Image -> Anzeige von Grafikdateien

Konfiguration Image-Effekt

  • ColorChange -> Farbwechsel mit optionalen Effekten beim Farbwechsel

Konfiguration ColorChange-Effekt

  • ColorScroll -> linienweises Scrollen von Farben

Konfiguration ColorScroll-Effekt

  • Fire -> Flammensimulation

Konfiguration Fire-Effekt

  • Fluid -> Simulation einer Flüssigkeit

Konfiguration Fluid-Effekt

  • Ticker -> Anzeigen eines durchlaufenden Texts

Konfiguration Ticker-Effekt

  • BeamShow -> Simulation einer Beamshow durch Linien und Punkte

Konfiguration BeamShow-Effekt

  • Plasma -> Plasma-Fraktal

Konfiguration Plasma-Effekt

  • Caleidoscope -> Simulation eines Kaleidoskops

Konfiguration Kaleidoskop-Effekt

Weitere Effekttypen sind für dieses Plugin nicht mehr geplant, sondern werden in DMXControl-V3.x realisiert.

Eine detaillierte Beschreibung jedes Effekts und der dazugehörigen Parameter ist in der Dokumentation nachzulesen.

Zusammenarbeit mit DMXControl

Das Plugin kann von DMXControl aus über Befehle gesteuert werden. Damit kann das Plugins auch in Szenen und Effekten erwendet werden.Als Beispiel werden hier die Funktionen beim Belegen von Buttons in der Kommandobox gezeigt.
Folgende Funktionen sind verfügbar:

  • Aufruf der Effekt-Speicherplätze rechts und links, z.B.3. Effekt links:

DMXC2 Manual Madmaxone left.jpg

  • Aufruf der Fade-Speicherplätze ohne Start des Fadevorgang, z.B. Fade Nr. 17:

DMXC2 Manual Madmaxone fade.jpg

  • Start des Fadevorgang, z.B nach rechts:

DMXC2 Manual Madmaxone fade right.jpg

  • Setzen des Faders auf Position A oder B (direktes Umschalten zwischen den Effekten) oder einen beliebigen Zwischenwert, z.B.:

DMXC2 Manual Madmaxone fader 30.jpg

  • Simulation des Beat-Signals für die Steuerung beat-abhängiger Effekte (ColorChange, ColorScroll, ...)

DMXC2 Manual Madmaxone beat.jpg


Achtung wichtiger Hinweis Beim Auswählen eines Effekts oder Fades muss das Flag "angegebenen Wert verwenden" gesetzt sein.


Zusammenspiel des Plugins mit dem Beamer-Tool-Plugin

Eine Visualisierung der Matrix mit dem Beamer-Tool-Plugin ist geplant, aber noch nicht fertig. Hierfür dient der TCPIP-Port in der Konfiguration und der (deaktivierte) Network-Button im Hauptfenster.

Interner MatrixSimulator

Mit dem internen MatrixSimulator erfolgt die Ausgabe der Matrix direkt in ein Fenster und nicht wie mit MxSim über DMXControl. Dies hat den Vorteil, dass die volle Auflösung (bis 50x50) der Matrix genutzt werden kann. Auch die zur Zeit noch vorhandenen Performanceprobleme beim DMX-Betrieb tauchen dann nicht auf. Der MatrixSimulator wird über den Button „MxSim“ eingeschaltet. Mit der Leertaste wird zwischen Fenster- und Vollbilddarstellung umgeschaltet und mit der <ESC>-Taste wird der Simulator wieder geschlossen.

Tipp(s)

Kleines Demovideo

Hinweise zum Demoprojekt

Hier noch einige Hinweise für die Bedienung des oben bereit gestellten Demoprojektes:

  • Demo-Projekt laden und z.B. im Projektverzeichnis von DMXControl entpacken
  • Das MadMaxOne-DDF von der DDF-download-Seite laden und im DMXControl-device-Verzeichnis entpacken
  • DMXControl neu starten
  • Das Matrixdemo-Projekt öffnen.
  • Im Menüpunkt "Plugins..." das Matrix-Plugin aktivieren. Das Plugin muss aber nicht konfiguriert werden, da eine Pluginkonfigurationsdatei für das Demoprojekt mit dem Projektnamen bereits vorhanden ist und diese automatisch eingelesen wird (daher auch die 100 als Adresse).
  • Danach im Menü "Fenster" den neuen Eintrag "Matrix" auswählen.
  • Mit dem Button "Load Effects" (Diskette->Matrix) die Datei "sand.MadMax" auswählen und öffnen. Diverse Effekte sollten unter left und right effects erscheinen.
  • Durch Anklicken der Checkbox "MxSim" erhält man ein separates Ausgabefenster. Vor dem eigentlichen Anzeigen könnte man es noch konfigurieren. Einfach ignorieren und "Starten" drücken.
  • Mit der Leertaste kann man das Ausgabefenster zwischen Vollbildmodus und Fenstermodus hin- und herschalten. Dafür muß aber das MxSim-Fenster das aktive Fenster sein (ein click hinein). Mit der Esc-Taste verschwindet das Anzeigefenster komplett.
  • Nun einfach den Audioplayer starten ... und den faszinierenden Anblick erleben ;-)
  • Selbstverständlich kann man das Ausgabefenster auch über einen Beamer projizieren.
  • Die Checkbox "DMX" kann für die Demo ausgeschaltet bleiben, da ja nicht wirklich DMX-Werte an eine Hardware-LED-Matrix gesendet werden sollen.

Viel Erfolg. Wir freuen uns über Feedback!

Einschränkungen und Probleme

Die größte Einschränkung ist, dass DMX-Control zur Zeit nur 1024 Kanäle unterstützt und damit die maximale theoretische Dimension der Matrix 341 Punkte nicht überschreiten kann. Da viele RGB-Devices jedoch mehr als 3 Kanäle belegen ist eine maximale Anzahl von 200-300 RGB-Devices realistischer. Ein weiteres Problem ist der Durchsatz des DMX-Busses, da bei bewegungsintensiven Effekten und hohen Auflösungen der Matrix die Belastung des DMX-Busses sehr hoch ist.

Sollten Fehler auftauchen, diese bitte im DMXControl-Bugtracker oder im DMXControl-Forum melden. Dies gilt selbstverständlich auch für Erweiterungswünsche.

Links und Referenzen


Downloads: Plugin: matrix.dll Anleitung: MadMaxOne.pdf
Demo-Video und das dazugehörige Demo-Projekt.
 

Arrow back.png Beamertool Plugin
OSC Receiver Plugin Arrow forw.png
Inhaltsverzeichnis
Meine Werkzeuge
Namensräume

Varianten
Aktionen
Navigation
DMXControl 2
DMXControl 3
Tipps und Tricks
Hardware
Berichte
In anderen Sprachen
Werkzeuge